PLC 16 DIO 4AIO OPCUA problems


I’m trying to set up the PLC 16DIO… but i keep getting a error “UPDATE action failed! Variable not defined: analog_input4”.

Is the PLC running as it should? The status says running but the update action failed seems to try so say something else.

As the port starts with 0 and the var_AI1…4 starts with 1 i´m also having problems figuring out what to do.

Anyone have any ideas?

Hi Martin,

Is this still an issue, or was it as the reply in the other thread with the “process image” suggested?



I think this is still an issue, but i´m note sure.
in the PLC you have analog_input0, analog_input1 and so on up to 3.

Where you name the varibales it starts with var_AI1 and up to 4.
I´m not sure if this is an issue when sending it onwards to the third-party but i seem to get some errors regarding this. (SETUP:Variable not found).

I´m not sure if this is the issue or if there is something else i´m doing wrong, right now i´m just trying to eliminate all possible sources of errors.



I solved it by changing to rack-PLC and now it works!

Thank you for your help