Uploading an Asset - Stuck at grey box


I´m very new to Simumatik so please bare with me.

I´m trying to upload a model that i have originaly created in sketchup and exported with a GLTF add-on as a .glb file.

When i import the file its purple and very beautiful in explorer and the software says everything went well. When i import it into a library and later to the actual platform its a grey 3d box.

I´m guessing its something very easy to fix but i can´t seem to find the answer in either the manual or after searching through google.

When I edit the component i have tried to add “as_convex_hull” on both collision - geometry - mesh and visual - geometry - mesh but nothing helps and right now i´m not even able to save my component.

Is there a guide to learn how to do this or could someone help in any way?



I should add that the error i´m getting is just a red circle with a X in it.

Hello Martin!

I’ll be happy to help you to the best of my knowledge. It’s hard to tell from your description what may be wrong. Can you please send me a copy of the model? martin.jacobsson@simumatik.com



Thank you so much, you now have an email on the way.

This is world class support!

Thanks again!


You may also try to do the steps under chapter “visual” in the motor contactor tutorial

i´ll look into that right away, thanks!


This solves it! I did not upload the model under “geometry - Mesh”.

Once more its proven that its better to finish all tutorials before running live on your own!

Thank you so much!

1 Like

Happy to hear it worked out :slightly_smiling_face:

You’re welcome!